5. The main menu

Main menu

 

By VEGA ZZ main menu, you can access to main functions. The item layout is organized in menu bar and sub-menu as shown in the following tables. The CmdName column contains the command names usable in the scripts to activate directly the menu functions (for more information see the SendVegaCmd program and the extended command section).

 

5.1 File menu

Item

Subitem

Accelerator

CmdName

Description

New

 

Ctrl+N

mNew

Delete all objects (molecules, surfaces, etc). A confirmation request is shown if the molecule has been changed.

Open

 

Ctrl+O

mOpen

Open one or more molecules (multiselection allowed), surfaces and MD trajectories. If a molecule is already present in the current workspace, a dialog is shown in order to select the placing mode (Append, Replace and New workspace).

Merge

 

Ctrl+M

mMerge

Merge the file properties into the molecule in the current workspace. It's possible to select the sections to merge (e.g. coordinates, connectivity, residue names, etc).

Database

Open

 

mDbOpen

Open or create a new database.

Explore

 

mDbExplore

Explore and manage the database contents.

Optical recognition   -

-

Optical structure recognition provided by OSRA plug-in.

Download From PDB - - Download a structure from Protein Data Bank (PDB). This function is provided by PowerNet plug-in.
From PubChem -

-

Download a molecule from PubChem by specifying its name.

From URL - - Download a molecule from a URL.
Optical structure recognition  

-

-

Recognize a structure and convert it to 3D from an image, PDF document or directly from a device (scanner, camera, etc).

Run script  

-

-

Run a script. This function is provided by PowerNet plug-in.

Save As...

 

Ctrl+S

mSave

Save the molecule/assembly. Remember that only the IFF format stores all atom information and this is useful to create snapshots of the current workspace.

Save trajectory

 

-

mSaveTraj

Save the current MD/docking trajectory converting it to the specified format. Cut/skip frame and remove atoms operations can be applied.

Save image

 

-

mSaveImg

Save the OpenGL view into a bitmap or a vector file.

Export to Excel

 

-

mExcel

Export the current molecule to Microsoft Excel.

Print

 

Ctrl+P

mPrint

Perform the hardcopy of the current 3D window representation. VEGA ZZ prints with the maximum resolution allowed by the printer for the best quality.

Demo mode

Run

Ctrl+D

mDemoStart

Start the demo.

Stop

-

mDemoStop

Stop the demo.

Music

-

mDemoMusic

If it's checked, when the demo run, the background music is played.

Titles

-

mDemoTitles

If it's checked, the subtitles are shown during the demo execution.

Last file(s)

 

-

-

It's the list of the last four files opened. Using these items, you can re-open the files directly without the use of the file requester of the Open item.

Exit

 

-

mExit

Close VEGA. If a molecule is loaded, a requester is shown.

 

5.2 Edit menu

Item

Subitem

Accelerator

CmdName

Description

Undo   Ctrl+Z mUndo

Undo the last operation. The default number of undo/redo levels is 20 and can be changed in Preferences dialog window.

Redo   Ctrl+Y mRedo Redo the previous operation.

Add

Atom

-

mAddAtom

Add one or more atom with specific hybridization and bond type.

Hydrogens

-

mAddHydrogens

Add the hydrogens.

Side chains

-

mAddChains

Add the aminoacid side chains. The bump-check is not performed.

Bonds

-

mAddBonds

Add one or more bonds.

Centroid

-

mAddCentr

Add one or more centroid (pseudo-atom).

Fragments

-

mAddFragments

Enable the access to the fragment libraries to build interactively the molecule.

Cluster

-

mAddCluster

Add a solvent cluster.

Ions

-

mAddIons

Add ions to the molecule.

Remove

Molecule

-

mRemoveMol

Remove one or more molecules.

Segment

-

mRemoveSeg

Remove one or more segments.

Residue

-

mRemoveResidue

Remove one or more residues.

Atom

-

mRemoveAtom

Remove interactively one or more atoms.

Invisible atoms

-

mRemoveInvisAtm

Remove all invisible atoms.

Centroids

-

mRemoveCentr

Remove all centroids.

Hydrogens

-

mRemoveHydrog

Remove all hydrogens from the molecule.

Apolar hydrog.

-

mRemoveHydrogApol

Remove the apolar hydrogens from the molecule.

Water

-

mRemoveWater

Remove water molecules from the assembly.

Bonds

-

mRemoveBonds

Remove one or more bonds.

All surfaces

-

mSurfRemove

Remove all calculated surfaces.

Graphic objects

-

mRemoveGraphObj

Remove all VEGA GL graphic objects.

Build

Solvent cluster

-

mBuildCluster

Show the dialog to build a solvent cluster.

Peptide - mBuildPeptide Show the peptide builder.
SMILES - mBuildSmiles Show the SMILES editor.
Combi SMILES - mBuildCombiSmiles Show the combinatorial SMILES builder.
IUPAC - mBuildIupac Show the IUPAC name editor.

Change

Atom/residue/chain

-

mEditAtm

Change atom, residue and chain properties. 

Bond type

-

mChangeBonds

Change the bond type.

Swap bonds

-

mSwapBonds

Swap two bonds.

Bond/Angle/torsion

-

mChangeTorsion

Change bond length, bond angle and torsion angle.

Secondary struct.

-

mChangeSecStruct Change the secondary structure of a protein.

Renumber residues

-

mRenumberRes

Renumber the residue sequence. It's possible renumber all atoms or selected only.

Coordinates

Apply transf.

-

mApplyTransf

Apply the transformation matrix to the atomic coordinates.

Invert Z coordinates

-

mInvertZ

Invert the Z coordinates in order to obtain the enantiomer.

Normalize

-

mNormalize

Normalize the coordinates, translating the center of mass to the axis origin.

Conversion to 2D - mConversion2D Convert the atom coordinates from any dimension to 2D.
Conversion to 3D - mConversion3D Convert the atom coordinates from any dimension to 3D.

Constraints

-

mConstraints

Select atom constraints for molecular dynamics simulations.

Molecules

Fix

-

mMolFix

Find molecules in the active/visible atoms.

Merge

-

mMolMerge

Merge together active/visible molecules.

Segments

Fix

-

mSegFix

Find the segments in the active/visible atoms.

Merge

-

mSegMerge

Merge the active/visible segments.

Cut

 

Ctrl+X

mCut

Cut the current 3D view and put it into the clipboard.

Copy

 

Ctrl+C

mCopy

Copy the current 3D view into the clipboard using the VEGA ZZ custom format.

Copy Special

 

-

mCopySpecial

Open a requester in order to select the format used to put the data into the clipboard.

Paste

 

Ctrl+V

mPaste

Paste the data from the clipboard.

 

5.3 View menu

Item

Subitem

Accelerator

CmdName

Description

Select

Molecule

-

mSelectMolecule

Select/unselect one or more molecule.

Segment

-

mSelectSegment

Select/unselect one or more segments

All

-

mSelectAll

Select all atoms.

None

-

mSelectNone

Unselect all atoms.

Invert

-

mSelectInvert

Invert the current selection. In other words, swap the invisible with the visible atoms.

Protein backbone

-

mSelectBackbone

Show the protein backbone.

DNA backbone

-

mSelectBackDNA Show the DNA backbone.

No hydrogens

-

mSelectNoHyd

Hide the hydrogens.

No apolar hydrogens

-

mSelectNoApolHyd Hide the apolar hydrogens.

No water

-

mSelectNoWater

Hide the water molecules.

Sup. atoms

-

mSelectSupAtm

Selection of the superficial atoms that are accessible by the solvent.

Unconstrained atoms

-

mSelectUnconstr Show the unconstrained atoms. For more details, see the constraints section.

Custom

-

mSelectCustom

Open the dialog box for custom selection.

Display

Wireframe

V

mShowWire

Switch the current display mode to wireframe, CPK dotted, CPK wireframe, CPK solid, ball & stick wireframe, ball & stick solid, stick wireframe, stick solid, trace and tube.

CPK dotted

mShowCpkDot

CPK wire

mShowCpkWire

CPK solid

mShowCpk

Ball & stick wire

mShowBallWire

Ball & stick Solid

mShowBall

Stick wire

mShowStickWire

Stick solid

mShowStick

Trace

mShowTrace

Tube

mShowTube

Settings

-

mShowSettings

Show the display settings dialog box.

Color

By atom

-

mColorByAtom

Set the molecule color by atom.

By residue

-

mColorByRes

Color the molecule by residue.

By chain

-

mColorByChain

Color the molecule by chain identificator.

By molecule

-

mColorByMol

Set the molecule color by molecule.

By segment

-

mColorBySeg

Color the molecule by segment.

By H-bond

-

mColorByHBond

Color the atoms by property to accept or donate H-bonds.

By charge

-

mColorByCharge

Color the atoms on the basis of the partial charges.

By constraint

-

mColorByConstr

Color the atoms by constraint value (blue fixed, green free).

By flex bonds

-

-

Color by flexible bonds. Two choices are possible: Normal (mColorByFbNorm) and AutoDock (mColorByFbAutoDock).

Selection

-

mColorSel

Color all displayed atoms with the specified color.

Settings

-

mColorSet

Show the Color settings dialog box.

Label atom

Off

-

mLblOff

No atom labels.

Name

-

mLblAtmName

Show the atom labels by name.

Element

-

mLblAtmElement

Show the atom labels by element.

Number

-

mLblAtmNumber

Show the atom labels by atom number.

Type

-

mLblAtmType

Show the atom labels by atom type (force field).

Charge

-

mLblAtmCharge

Show the atom labels by atom charge.

Chirality

-

mLblAtmChiral Show the R/S chirality of the asymmetric atoms.

Fixing value

-

mLblAtmFixVal

Show the atom labels by fixing value (constraint).

Residue

-

mLblResidue

Show the residue labels with name, number and chain.

Residue name

-

mLblResName

Show the residue name labels.

Residue number

-

mLblResNumber

Show the residue number labels.

Light

 

-

mLight

Open the light control window.

Center  

-

mCenterView Center and zoom the current atom selection.

Reset

                        

-

mResetView

Reset the current view, resetting rotations, translations and scale factor.

Animation

 

A

mAnimation

If it's checked, the animation mode is enabled. You can use the mouse and/or the keyboard to change the animation.

Console

 

-

mConsole

Show/hide the console window.

3D controls

 

-

m3dControls

Show/hide the 3D control window.

Tool bars

Standard

-

mTbStandard

Show/hide the tool bar.

Tools

-

mTbTools

Information

 

-

mMoleculeInfo

Show the information about the molecule.

 

5.4 Calculate menu

Item

Subitem

Accelerator

CmdName

Description

Charge & Pot.

 

-

mCalcCharge

Assign the atomic charges and/or potentials.

Ammp

Minimization

-

mAmmpMin

Open the AMMP dialog window to perform an energy minimization.

Conformational search

-

mAmmpTsrc

Open the AMMP dialog window to perform a conformational search.

NAMD  

-

mNAMD

Open the NAMD dialog window to perform molecular dynamics and energy minimizations.

Mopac

 

-

mCalcMoPac

Open the dialog window for Mopac calculations.

Surface

 

-

mSurface

Calculate, color and manage the surfaces.

Docking Interactions

-

mInteractions Open the dialog for the evaluation of the interactions.

Analysis

 

-

mAnalysis

Open the dialog box to analyze a molecular dynamic trajectory file.

Similarity

 

-

mSimilarity

Show the similarity toolbox.

Isotopic distribution

 

-

mIsotopicDist

Calculate the isotopic distribution of the molecule in the current workspace.

Protein Check

AA chirality

-

mChkAaChirality

Check the alpha carbon chirality. It reports warnings and shows the aminoacids if they are D or pseudo D. Pseudo D are aminoacids with distorted geometry that can be converted to L by energy minimization.

Peptidic bonds

-

mChkPeptBond

Check the geometry of the peptidic bonds. If cis bonds are detected, they are show in the main window.

Bond length

-

mChkBndLen

Check the lengths of all bonds in the molecule. If the length is less or greater than the sum of covalent radii of the two atoms involved in the bond increased or reduced of 20%, the invalid bond is displayed in the graphic environment and a warning message is shown in the console window. To hide the distance violations, open the context menu and select  Measure Remove monitors.

Missing res.

-

mChkMisRes

Search the missing residues in the aminoacid sequence checking the residue numbers.

Ring inter.

-

mChkRingInter

Search the intersections between bonds and rings. It works with non-peptidic molecules also.

AA contacts

-

mChkAaContacts

Show the contacts between aminoacids. For each residue is shown a label of two numbers: the first one is the number of contacts, the second is the average distance between the residues.

ERRAT -

-

Analyzes the statistics of non-bonded interactions between different atom types and plots the value of the error function versus position of a 9-residue sliding window, calculated by a comparison with statistics from highly refined structures (for more information, click here). Function provided by PowerNet plug-in.

ProCheck -

-

Checks the stereochemical quality of a protein structure by analyzing residue-by-residue geometry and overall structure geometry (for more information, click here). Function provided by PowerNet plug-in.

Prove -

-

Calculates the volumes of atoms in macromolecules using an algorithm which treats the atoms like hard spheres and calculates a statistical Z-score deviation for the model from highly resolved (2.0 Å or better) and refined (R-factor of 0.2 or better) PDB-deposited structures (for more information, click here). Function provided by PowerNet plug-in.

VADAR -

-

VADAR (Volume, Area, Dihedral Angle Reporter) is a compilation of more than 15 different algorithms and programs for analyzing and assessing peptide and protein structures from their PDB coordinate data. The results have been validated through extensive comparison to published data and careful visual inspection (for more information, click here). Function provided by PowerNet plug-in.

Verify3D -

-

Determines the compatibility of an atomic model (3D) with its own amino acid sequence (1D) by assigned a structural class based on its location and environment (alpha, beta, loop, polar, non-polar etc) and comparing the results to good structures (for more information, click here). Function provided by PowerNet plug-in.

What check -

-

Derived from a subset of protein verification tools from the WHATIF program (Vriend, 1990), this does extensive checking of many sterochemical parameters of the residues in the model (for more information, click here). Function provided by PowerNet plug-in.

ChemSol     -

Calculate the solvation free energies using Langevin Dipoles (LD) solvation model, in which the solvent is approximated by polarizable dipoles fixed on a cubic grid. Function provided by ChemSol plug-in.

Escher NG   - -

Show the Escher NG dialog window to perform protein-protein docking calculations. Function provided by Escher NG plug-in.

Pockets   - -

Find the pockets inside a macromolecule. Function provided by Pockets plug-in.

Protein pKa   - - Predict the protein pKa by PropKa plug-in.
Ramachandran plot   - -

Show the Ramachandran plot of the protein in the current workspace. Function provided by Ramaplot plug-in.

Stride Table - - Secondary structure analysis provided by Stride plug-in.
Chart - -
Standard run - -

 

5.5 Tools menu

Item

Subitem

Accelerator

CmdName

Description

GraphED

 

-

mGraphEd

Start the graphic editor for data manipulation.

MiniED

 

-

mMiniEd

Start the mini text editor integrated in VEGA ZZ.

WinDD

 

-

mWinDD

Execute WinDD data decompressor software.

VEGA On-line  

-

mVegaOnLine

Open the Web browser accessing to the VEGA On-line service.

Task Manager

 

Ctrl+T

mTaskMan

Open the integrated task manager to manipulate the running tasks (e.g. Mopac, BioDock, etc).

Plug-in configuration

 

-

-

Sub-menu for the plug-in configuration. It could be customized by the plug-ins.

HID configuration

 

-

mConfigHID

Open the dialog window to configure the human interface devices (mouse and joystick).

Host configuration

 

-

mConfigHost

Configure the hosts to run remote calculation jobs.

Preferences

 

-

mPreferences

Edit preferences.

Mass spectrometry tool  

-

-

Start the Mass spectrometry plug-in if it's installed. This plug-in is available for free as optional component.

Database search ChEBI - -

Chemical Entities of Biological Interest (ChEBI) is a freely available dictionary of molecular entities focused on ‘small’ chemical compounds. The term ‘molecular entity’ refers to any constitutionally or isotopically distinct atom, molecule, ion, ion pair, radical, radical ion, complex, conformer, etc., identifiable as a separately distinguishable entity. The molecular entities in question are either products of nature or synthetic products used to intervene in the processes of living organisms (for more information, click here). Function provided by PowerNet plug-in.

DrugBank - -

The DrugBank database is a unique bioinformatics and cheminformatics resource that combines detailed drug (i.e. chemical, pharmacological and pharmaceutical) data with comprehensive drug target (i.e. sequence, structure, and pathway) information. The database contains drug entries including FDA-approved small molecule drugs, FDA-approved biotech (protein/peptide) drugs, nutraceuticals and experimental drugs. Additionally, more than 2,500 non-redundant protein (i.e. drug target) sequences are linked to these FDA approved drug entries. Each DrugCard entry contains more than 100 data fields with half of the information being devoted to drug/chemical data and the other half devoted to drug target or protein data (for more information, click here). Function provided by PowerNet plug-in.

eMolecules - -

eMolecules is the world’s most comprehensive openly accessible search engine for chemical structures. Each day, over 2,000 chemistry professionals visit the web site to find valuable information that helps them do their work more productively. The database contains chemical data from more than 150 suppliers updated weekly and quarterly and references links to many prominent sources of public data for spectra, physical properties and biological data, including NIST WebBook, National Cancer Institute, DrugBank and PubChem (for more information, click here). Function provided by PowerNet plug-in.

Google - -

Google is the most used search engine on the Web. Function provided by PowerNet plug-in.

MMsINC - -

MMsINC is a free web-oriented database of commercially-available compounds for virtual screening and chemoinformatic applications. MMsINC contains over 4 million non-redundant chemical compounds in 3D formats (for more information, click here). Function provided by PowerNet plug-in.

NIST Chemistry - -

The NIST Chemistry WebBook provides users with easy access to chemical and physical property data for chemical species through the internet. The data provided in the site are from collections maintained by the NIST Standard Reference Data Program and outside contributors. Data in the WebBook system are organized by chemical species. The WebBook system allows users to search for chemical species by various means. Once the desired species has been identified, the system will display data for the species (for more information, click here). Function provided by PowerNet plug-in.

PubChem - -

PubChem provides information on the biological activities of small molecules and it's a component of NIH's Molecular Libraries Roadmap Initiative. PubChem includes substance information, compound structures, and BioActivity data in three primary databases: Pcsubstance, Pccompound and PCBioAssay, respectively. Function provided by PowerNet plug-in.

Ptable   - -

Periodic table of elements. It requires an Internet connection and this function is provided by PowerNet plug-in.

Dhrystone test   - -

Test to perform the CPU performance. This plug-in is not installed by default.

 

5.6 Bioinformatics

Item

Subitem

Accelerator

CmdName

Description

Web resources

 

-

mBioResources

Start the web browser to explore the bioinformatics resources on the Web. 

ClustalX   - - Multiple alignment program. Function provided by ClustalX plug-in.
NJPlot   - - Philogenetic tree visualization. Function provided by ClustalX plug-in.
Unrooted   - - Unrooted philogenetic tree visualization. Function provided by ClustalX plug-in.
Predator   - -

Protein secondary structure prediction. Function provided by Predator plug-in.

 

5.7 Help menu

Item

Subitem

Accelerator

CmdName

Description

VEGA ZZ manual

 

F1, Ctrl+H

mHlpContents

Open this help.

Mopac 7 manual

 

-

mHlpMopac

Open the Mopac manual.

Mopac 2012 manual  

-

mHlpMopac2012 Open the on-line Mopac 2009 manual.
NAMD user's guide  

-

mHlpNAMD Open the on-line NAMD user's guide.

Keys

 

-

mHlpKeys

Show a list window of all key with the associated functions.

Last error

 

-

mHlpLastErr

Show the last error message.

Explore data directory  

-

mHlpDataDir Explore the data directory.

VEGA on the Web

 

-

mHlpWeb

Open the VEGA main page on the Web.

Check for updates

 

-

mHlpChkUpdates

Check for new updates and if they are available, the user can decide to download and install them automatically.

About

 

-

mHlpAbout

Show the copyright message.